Degraded Contract Performance due to HelloSign Maintenance.
Incident Report for Gigwell
Resolved
This incident has been resolved.
Posted May 08, 2019 - 11:30 PDT
Update
HelloSign has indicated the issue has been resolved.
Posted May 08, 2019 - 11:16 PDT
Investigating
HelloSign is currently experiencing issues.

Gigwell E-Signatures are currently unavailable.

We will update this incident as we know more.
Posted May 08, 2019 - 11:04 PDT
This incident affected: Book Dashboard and User Portal.